All times are UTC-06:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Mon Mar 15, 2010 1:33 pm 
Offline

Joined: Fri Mar 12, 2010 10:32 am
Posts: 33
Hello

I continure on setting up my efika mx box

i installed mysql and ruby on rails, using first apt-get but there is some problems with the debian package as usual with rails so i reinstalled rails via the gem installer (an apt-get style one).
Then i launch a web application on the port 3000

but when i try to connect to port 3000 the conection is refused. An nmap on my efika mx shows only two open ports 21 and 22.
Iptables does not seem to be installed.

did i forgot something to tune it up ?

Thanks for your answer.
Nicolas


Top
   
PostPosted: Fri Mar 19, 2010 12:43 pm 
Offline
Site Admin

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1589
Location: Austin, TX
Quote:
Hello

I continure on setting up my efika mx box

i installed mysql and ruby on rails, using first apt-get but there is some problems with the debian package as usual with rails so i reinstalled rails via the gem installer (an apt-get style one).
Then i launch a web application on the port 3000

but when i try to connect to port 3000 the conection is refused. An nmap on my efika mx shows only two open ports 21 and 22.
Iptables does not seem to be installed.

did i forgot something to tune it up ?

Thanks for your answer.
Nicolas
Is UFW enabled and running? If so.. break a hole in it or disable it ("sudo service ufw stop"). If you are running a desktop you can use the GUI but otherwise you will have to go find the UFW manual (it's online, or man ufw).

It may be that the default setup for the firewall (or iptables) is that the 21 and 22 ports are opened by the packages installed (sshd and ftpd) when they get pulled in. As a non-packaged app nothing is opening the firewall port.

_________________
Matt Sealey


Top
   
 Post subject:
PostPosted: Sat Mar 20, 2010 1:51 pm 
Offline

Joined: Fri Mar 12, 2010 10:32 am
Posts: 33
everything is working now.

I don't know why iptables nor nufw are installed and the port 3004 opened byhimself.

Everything is working fine now.

nice machine

Thanks

Nico


Top
   
 Post subject:
PostPosted: Sun Mar 21, 2010 9:49 am 
Offline
Site Admin

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1589
Location: Austin, TX
Quote:
everything is working now.

I don't know why iptables nor nufw are installed and the port 3004 opened byhimself.

Everything is working fine now.

nice machine

Thanks

Nico
iptables is part of the base linux, ufw is Ubuntu's pretty interface to iptables, and is part of ubuntu-standard.

Glad it started working for you :)

_________________
Matt Sealey


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group