Power Developer

emerge problems : help needed !
Page 1 of 1

Author:  lugduweb [ Mon May 01, 2006 10:00 am ]
Post subject:  emerge problems : help needed !

Hi !

I have problems with emerge : I would like to emerge 'kde' or 'gnome', but in both case there is a problem because of "Cyrus SASL" seems to be missing.
Configur error : could not locate Cyrus SASL
ERROR : net-nds/openldap-2.2.28-r3 failed
Function econf, Line 495, Exitcode 0
econf failed
So if I try a 'emerge sasl' I have the following error message :
All ebuilds that could satisfy "sasl" have been masked
One of the following packages is required to complete your request
app-xemacs/sasl-1.12 (masked by ~ppc keyword)
So, then if I change ACCEPT_KEYWORDS="ppc" to "~ppc" in /etc/make.conf, it's going further but I have the following message instead :
configure error : cannot enable LDAPDB plugin : OpenLDAP library located but incompatible
As I'm a gentoo-rookie, I really don't know what to do now.
So, it seems I'm struck but maybe somebody had the same problem or knows what I should do.

Could somebody help me on this ?

Author:  frostwork [ Mon May 01, 2006 10:17 am ]
Post subject: 

Hi, geoffrey!

I'm almost sure that "sasl" is a different package than your required
"cyrus-sasl". Maybe you should try to
emerge cyrus-sasl
... Good luck so far!

Author:  nixnut [ Mon May 01, 2006 10:19 am ]
Post subject: 

dev-libs/cyrus-sasl is what you are looking for.

BTW adding ~ppc to KEYWORDS in /etc/make.conf is a bit drastic. For individual packages it is better to add them to /etc/portage/package.keywords

Author:  lugduweb [ Mon May 01, 2006 10:23 am ]
Post subject: 

@frostwork : damn ! you're right !
I was emerging the wrong package (fool I am !)

Thanks very much (indeed it's nice to see you on this thread again ;-) )

@niknut : I had also tried the "/etc/portage/package.keywords" way without success. Now I understand why :)

Thx both.

Author:  lugduweb [ Mon May 01, 2006 10:28 am ]
Post subject: 

with "cyrus-sasl" I still have the same error.
I don't understand !

Author:  nixnut [ Mon May 01, 2006 10:30 am ]
Post subject: 

Which version of openldap do you have installed now?
emerge -p openldap should tell you

Author:  lugduweb [ Mon May 01, 2006 10:31 am ]
Post subject: 

bad post...

Author:  nixnut [ Mon May 01, 2006 10:35 am ]
Post subject: 

Ok, I see (on the gentoo forums) more people ran into this.
# USE="-sasl" emerge openldap
# emerge cyrus-sasl openldap

The explanation is that a circular dependency mess occurs if you have both the ldap and sasl USE flags enabled. That results in openldap needing cyrus-sasl installed and openldap needing cyrus-sasl.

Author:  lugduweb [ Mon May 01, 2006 10:43 am ]
Post subject: 

err... don't know.

emerge -p openldap gives me this :

USE=berkdb crypt ldap postgres ssl

USE=berkdb crypt ldap postgres ssl ipv6 perl readline samba sasl ssl tcpd

Maybe some USE flags are missing ?

My current USE flags are :
USE="ooc altivec nptl socks5 smartcard pcsc-lite ldap bzip2 Xaw3d lesstif tetex mysql postgres sasl javascript tiff howl samba jack bash-completion xml libclamav browserplugin mozilla sdl arts sqmite vorbis libcaca jpeg2k zeroconf ieee1394 pda snmp wifi xine guile flac speex gstreamer curl cdr dvdr dvd dxr3 ffmpeg v4l v4l2 vcd graphviz"

(ouf :-P)

Author:  lugduweb [ Mon May 01, 2006 10:47 am ]
Post subject: 

OK, I'm going to try (my previous post was the answer to your previous question ;-) )

Author:  lugduweb [ Tue May 02, 2006 4:48 am ]
Post subject: 

@nixnut : that was the right solution.
Thank you very much !

Another quick question : sometimes my connexion stops and emerge finishes on error.
If I emerge with the same command it starts from the begining.
I saw there was a "--resume" option. Is that enough ?
Is there a way to known which was emerged with success when you emerge several packages at the same time :

ex: emerge kde gnome ... etc...

Author:  nixnut [ Tue May 02, 2006 9:04 am ]
Post subject: 

emerge --resume will restart the last emerge command. It will resume with the package it was busy emerging when it was interupted.

emerge --resume --skipfirst will restart the last emerge command starting with the next package in the list. This is useful when a package fails due to some error you can't fix right away or don't care to fix at that moment. But if one of the next packages depends on the one that failed to emerge that one will fail too of course.

In your case (a connection that goes down) emerge --resume should be enough to continue the emerge. You may want to do an emerge -f <package-foo> first to download the sources for package-foo and the dependencies that need to be emerged. That way a connection that goes down won't interrupt the emerge process once all the needed sources are on your system.

the package portage-utils contains a handy tool called qlop that shows information from the log file /var/log/emerge.log.
qlop -l | tail show a list of the last packages that were emerged.

Author:  lugduweb [ Tue May 02, 2006 11:19 am ]
Post subject: 

Thanks again for this precious information.

Author:  nixnut [ Wed May 03, 2006 1:32 pm ]
Post subject: 

Thanks again for this precious information.
My pleasure :)

Not that I won't try to help out answering questions here on ppczone.org, but there are some good resources available elsewhere you can use to try find an answer to questions you may run into.

Although I'm of course biased (being a moderator there) I can recommend forums.gentoo.org as a pretty good source of information on all sorts of gentoo related problems and questions. Naturally there's a forum for Gentoo on PPC too.

And the people hanging out on irc in #gentoo-ppc on the freenode network are generally a friendly and helpful crowd too.

Author:  lugduweb [ Wed May 03, 2006 4:03 pm ]
Post subject: 

OK, but talking with you on this PPC forum is a pleasure ;-)

Page 1 of 1 All times are UTC-06:00
Powered by phpBB® Forum Software © phpBB Group