All times are UTC-06:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Fri Aug 19, 2011 5:27 am 
Offline

Joined: Fri Aug 19, 2011 5:08 am
Posts: 4
I've upgraded my smart top to maverick-20110722.img.xz
and installed KDE and Gambas2. KDE works OK.

Gambas2 doesn't start up properly - instead it runs gbx2 and that consumes all the available CPU resources :(
Please point if there is a fix available, or if I can do something to fix it, please suggest and I will try.

Thanks.

Joe


Top
   
PostPosted: Wed Sep 07, 2011 3:05 am 
Offline

Joined: Fri Aug 19, 2011 5:08 am
Posts: 4
Reply from Gambas mailing list:
-------------------------------

Gambas 2 already runs some project on ARM, but two ARM computers are well-
known to be very different!

Go to the directory of the Gambas 2 project you want to run, and use the
debugger. Hit CTRL+C to stop it when it loops, and send me the backtrace.

$ cd /path/to/my/gambas/project
$ gdb gbx2
...
(gdb) run
...
^C
(gdb) bt
...

Please try to compile the latest version of gambas, and with debugging
information enabled. Try to compile with and without optimization too, to see
if something changes.

Regards,

--
Benoît Minisini


Top
   
PostPosted: Wed Sep 07, 2011 12:58 pm 
Offline

Joined: Fri Aug 19, 2011 5:08 am
Posts: 4
Results of running gdb:
-----------------------

~/code/gambas/app1$ gdb gbx2
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "arm-linux-gnueabi".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/gbx2...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/gbx2
[Thread debugging using libthread_db enabled]
^C
Program received signal SIGINT, Interrupt.
0x0001850a in ?? ()
(gdb) bt
#0 0x0001850a in ?? ()
#1 0x0001ee68 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group