All times are UTC-06:00




Post new topic  Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Fri Nov 16, 2007 8:43 am 
Offline

Joined: Thu Nov 11, 2004 8:40 pm
Posts: 5
Got my Efika a few days ago from GGS-Data. It was pre-installed with Xubuntu. I created a user ID and logon and it works well so far, with one exception:

I can't reach the Internet. I also can't reach my router. I got into network configuration and set ETH0 for DHCP. I worked with it a bit, trying slightly different settings. Sometimes the little light at the ethernet cable plug-in point lights up. I don't know if that means "communicating" or "trying to communicate." But I just can't access Internet or the router.

I posted about this on morphzone.org. SoundSquare referred me here to this forum and also gave me the advice to make some changes to "interfaces" file (add line "/etc/init.d/network start" at end. This is via the text editor sudo by typing "sudo nano -w interfaces." I did make the change and rebooted etc. Still no dice. Don't know if it is causing problems but it seems that the Xubuntu network configuration tool also changes the interfaces file.

The non-commented out lines of my interfaces file are as follow:

auto lo
iface lo inet loopback
iface gre0 inet dhcp
iface eth0 inet dhcp
auto gre0
auto eth0
/etc/inet.d/network start

I don't know what "gre0" is and I tried commenting the gre0 lines out, but I think Xubuntu put them back, not sure though. I tried with three or four minor changes to "interfaces."

I make use of a Linksys router. The ethernet cable is the same as I run to my Pegasos where I get a successful connection (I'm just unplugging the Peg's ethernet to try the Efika). I don't think the network difficulty is anywhere but on the Efika. Any help anyone can provide is welcome!


Top
   
 Post subject:
PostPosted: Fri Nov 16, 2007 9:41 am 
Offline

Joined: Sun May 08, 2005 8:46 pm
Posts: 559
Location: Paris
Quote:
I posted about this on morphzone.org. SoundSquare referred me here to this forum and also gave me the advice to make some changes to "interfaces" file (add line "/etc/init.d/network start" at end.
you misunderstood me.

here's what Peter wrote about it :
Quote:
I found one serious problem: there is no network available after installation. To fix this (if you have DHCP on your network) is to edit as root /etc/network/interfaces and remove the # sign from the beginning of the last line, and execute
Code:
/etc/init.d/network start
so from what you can read here's what you have to do :
Code:
sudo nano -w /etc/network/interfaces
then remove the # sign from the beginning of the last line in this file. Save changes.

back to prompt type :
Code:
/etc/init.d/networking start
hope it solves your issue (it should).


Last edited by SoundSquare on Fri Nov 16, 2007 2:40 pm, edited 1 time in total.

Top
   
 Post subject:
PostPosted: Fri Nov 16, 2007 10:16 am 
Offline

Joined: Thu Nov 11, 2004 8:40 pm
Posts: 5
Okay, I did read you wrong but the instructions you gave don't exactly fit my installation. The last line in my "interfaces" file is "auto eth0" and doesn't have any "#" in it. What is the last line that should be there according to your setup?

Also, when I type "/etc/init.d/network start" I get a "no such file or directory" message. The closest thing to a network file in my init.d directory is a file called "networking." When I type "/etc/init.d/networking start" I get an "ifup: failed to open statefile /var/run/network/ifstate: Permission denied." Same thing when I use "networking stop," "networking force-reload," or "networking restart."

I shouldn't be getting any "permission denied" since I use my primary (only) logon and can write to "interfaces" and so on.


Top
   
 Post subject:
PostPosted: Fri Nov 16, 2007 11:42 am 
Offline

Joined: Fri Sep 24, 2004 1:39 am
Posts: 429
Location: Secure Networks / Sweden
Since you used sudo when you edited your file
you recieved temporary root privileges.

Then you tried to start the network w/out sudo,
which means no root.

sudo /etc/init.d... start


Top
   
 Post subject:
PostPosted: Fri Nov 16, 2007 2:37 pm 
Offline

Joined: Sun May 08, 2005 8:46 pm
Posts: 559
Location: Paris
yes sorry, it's "networking" and not "network" (i even corrected it in the other thread...shame).
Code:
sudo /etc/init.d/networking start


Top
   
 Post subject:
PostPosted: Fri Nov 16, 2007 3:27 pm 
Offline

Joined: Thu Nov 11, 2004 8:40 pm
Posts: 5
Well, I typed it with "sudo" like you said, and it says "configuring network interfaces [OK]" after that. But I still can't connect to Internet or even the router. In other words it acts just the same as it has been.

Is there perhaps some overall setting in Network utility that I need to set, or that could be set incorrectly for me right now? Under General it says host name is "efika" and domain name is blank. The Automatic Service Discovery is unchecked (though I have had it as checked previously). Under DNS it has 192.168.1.5. I dunno what that is. It's not my router. Search Domains has "lan" listed. The last tab, Hosts, has many things listed including "127.0.0.1 localhost."

Thanks very much for trying to help, not sure at all why I'm having this network trouble when the Efika and Xubuntu installation seem otherwise okay.

Also, please look and tell me what is that last line in interfaces I'm supposed to uncomment. Maybe I should type it back in, whatever it is?


Top
   
 Post subject:
PostPosted: Sat Nov 17, 2007 2:25 am 
Offline

Joined: Fri Sep 24, 2004 1:39 am
Posts: 429
Location: Secure Networks / Sweden
I don't think you need anything under Search domains.
DNS should be either your router or your ISP DNS servers.

Do you get any IP-address at all if you type "/usr/sbin/ifconfig"?

The network is eth0.


Top
   
 Post subject:
PostPosted: Sat Nov 17, 2007 3:38 am 
Offline

Joined: Sun May 08, 2005 8:46 pm
Posts: 559
Location: Paris
seems like you don't have DHCP enabled. Do you have a dhcp server enabled in your router ? (i guess so if you used it for the install).

make sure you have dhcp enabled in your /etc/networks/interfaces file
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth0

# The primary network interface
iface eth0 inet dhcp


Top
   
 Post subject:
PostPosted: Sat Nov 17, 2007 7:03 am 
Offline

Joined: Thu Nov 11, 2004 8:40 pm
Posts: 5
I edited my interfaces to be like the one SoundSquare provided. I changed the entry under Domain names in the Xubuntu network configuration tool to be my router (it looked like it may have been set to some other router).

Unfortunately, still no luck. When I run usr/sbin/ifconfig it gives me some text starting with:

Link encap: Local Loopback
inet addr: 127.0.0.1 Subnet mask: 255.0.0.0
inet 6 addr: 1/128 Scope = host
UP LOOPBACK RUNNINING MTU:16436 Metric 1

And then zeros for RX Packets, TX packets and everything else.

Perhaps it is compound problem with the Efika hardware not liking my Linksys router or vice versa. Not sure what else to try except perhaps adding my router's IP under Hosts in the network configuration tool or plugging in static values on the Efika instead of selecting DHCP.

I did not install from the network. The machine came preinstalled.

Also noticed a user describing similar problems at ubuntuforums.org: http://ubuntuforums.org/showthread.php?t=592111.


Top
   
 Post subject:
PostPosted: Sun Nov 18, 2007 8:40 am 
Offline

Joined: Sun May 08, 2005 8:46 pm
Posts: 559
Location: Paris
alright, can you provide here what you get with :
Code:
# ifconfig eth0
it seems like eth0 isn't active in your system.

setting your router as a domain name is useless as i suppose you don't have a domain based network. Setting the router IP into the hosts file shouldn't change anything but at least it's harmless.

try to set eth0 up with the following :
Code:
# ifup eth0
and tell me how it goes.

you can try to set your network interface with a static ip address, still in the interfaces file :
Code:
iface eth0 inet static

address 192.168.0.5

netmask 255.255.255.0

gateway 192.168.0.1


of course these values are an example, change the gateway IP by your router IP.

good luck, keep us tuned.


Top
   
 Post subject:
PostPosted: Sun Nov 18, 2007 10:44 pm 
Offline

Joined: Thu Nov 11, 2004 8:40 pm
Posts: 5
I am traveling this week and won't be working with the Efika. I will give your suggestions a try when I get back home. I am really thankful for the help.


Top
   
 Post subject:
PostPosted: Mon Mar 03, 2008 12:56 pm 
Offline

Joined: Wed May 03, 2006 3:15 pm
Posts: 15
Got the same problem here, but its now solved.

Delete the # in the last line worked only, if you didnt try to fix it with the standard-network-gui. After that, the config has changed, but didnt work. The sequence changed too.

Only solution is to change the whole file. I copied this one from my Pegasos-Ubuntu:

---cut here-------

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
-- here too --------------

Works fine. The network-info shows "no network", but its ok.


Top
   
 Post subject:
PostPosted: Tue Mar 23, 2010 4:30 am 
Offline

Joined: Tue Mar 23, 2010 4:07 am
Posts: 1
Location: uk
yes Palmiga is right..i had same problem but now solved as Palmiga said

_________________
642-481
650-251
HP0-J41


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 13 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group