All times are UTC-06:00




Post new topic  Reply to topic  [ 20 posts ] 
Author Message
PostPosted: Mon Feb 18, 2008 5:01 pm 
Offline
Site Admin

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1589
Location: Austin, TX
Just a small note to push everyone who cares to the Efika Firmware Update Platform Support page.

We noticed some problems with the original firmware as shipped in the initial batch of systems - this was fixed in subsequent production runs but the firmware was never published for anyone else since it was such a minor set of problems that nobody really noticed (Linux managed to gloss over it with a hack). The ONLY user-facing difference is that AC97 is properly enabled on boot, so the /* EFIKA HACK */ in the Linux kernel driver can be removed with the new firmware. This should improve acceptance and development of that driver if users and developers wish that, and reduces Linux requirement on such hacks for "firmware glitches" (and obseletes 5 lines in efika.forth)

Anyway, to unify all the boards under the same firmware revision, we're publishing the 20070122 firmware update, so that we can get people on the same, common firmware level.

You can find it here; and it's listed in the Platform Support box on the front page where everyone can see it when they drop onto the site :)

http://www.powerdeveloper.org/platforms/efika/firmware

Note, this is not the firmware everyone craves with yaboot and all that stuff, but it does mean we can start to clean things up for everybody.

_________________
Matt Sealey


Top
   
PostPosted: Tue Feb 19, 2008 1:35 am 
Offline

Joined: Sat Nov 03, 2007 10:43 am
Posts: 38
Location: France
Thanks for publishing this. No more AC97 hack. :)


Top
   
 Post subject:
PostPosted: Tue Mar 04, 2008 2:16 am 
Offline

Joined: Tue Feb 14, 2006 2:01 pm
Posts: 75
Location: Germany
finally! thanks a lot! :-)

EDIT: works perfectly!


Top
   
 Post subject: netboot firmware update
PostPosted: Fri Mar 07, 2008 5:39 pm 
Offline

Joined: Fri Feb 03, 2006 7:32 am
Posts: 2
Location: Cobourg, Ontario, Canada
No need to use a disk or USB device. Just drop it onto a tftp server and then :

boot eth:ip_of_server,ip_of_client,update_e_20070122,ip_of_router update_e_20070122

and it runs

Welcome to Pegasos BIOS Update

WARNING: THIS TOOL CAN RENDER YOUR SYSTEM USELESS
YOU BETTER READ THE MANUAL CAREFULLY

Running on machine type 1
<ENTER> to start, any other key aborts
DO NOT INTERRUPT THIS PROGRAM
UNDER ANY CIRCUMSTANCES

Updating...*................Done.
Bye.
Program EFIKA 5K2 Boot Strap [RELEASE BUILD] (c) 2002-2007 bplan GmbH (BUILD 20070122 84240)
Running on CPU PVR: 0x80822014
Running on system SVR: 0x80110022
BIOS Code position: 0xFFF040D0
Setup System Config... Done.
Setup Memory Config... Done.
Setup PCI... Done.
Setup ATA... Done.
Setup USB... Done.
Setup ETH... Done.
Setup AC97... Done.
Memory Test skipped (Warmboot detected)
cpu0: PowerPC,G2 CPUClock 396 Mhz BUSClock 132 Mhz (Version 0x8082,0x2014)
channel 0 unit 0 : ata | IC25N015ATDA04-0 | DA2OA70A
ATA device not present or not responding
Welcome to SmartFirmware(tm) for bplan EFIKA5K2
Version 1.3 (20070122084838)
SmartFirmware(tm) Copyright 1996-2001 by CodeGen, Inc.
All Rights Reserved.
Pegasos BIOS Extensions Copyright 2001-2007 by bplan GmbH.
All Rights Reserved.
ok


Top
   
 Post subject:
PostPosted: Wed Mar 12, 2008 7:49 pm 
Offline
Genesi

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1422
Dennis?

Are you still alive?

R&B :)

_________________
http://bbrv.blogspot.com


Top
   
 Post subject: very alive ...
PostPosted: Sun Mar 16, 2008 7:05 pm 
Offline

Joined: Fri Feb 03, 2006 7:32 am
Posts: 2
Location: Cobourg, Ontario, Canada
http://gcc.gnu.org/ml/gcc-testresults/2 ... 01254.html

did that on an EFIKA


Top
   
 Post subject:
PostPosted: Sun Mar 16, 2008 7:21 pm 
Offline
Genesi

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1422
Great!

Then, you will really like the new EFIKA coming with more memory...

R&B :)

_________________
http://bbrv.blogspot.com


Top
   
 Post subject: update?
PostPosted: Sun Jul 26, 2009 8:35 am 
Offline

Joined: Tue Sep 28, 2004 9:03 pm
Posts: 45
what happened with the update? the link ( http://www.powerdeveloper.org/asset/by-id/48 ) is broken :(


Top
   
 Post subject: Re: update?
PostPosted: Sun Jul 26, 2009 10:07 am 
Offline
Site Admin

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1589
Location: Austin, TX
Quote:
what happened with the update? the link ( http://www.powerdeveloper.org/asset/by-id/48 ) is broken :(
Oops. My mistake. I will put this back from backup ASAP.

_________________
Matt Sealey


Top
   
 Post subject:
PostPosted: Sun Jul 26, 2009 5:46 pm 
Offline

Joined: Tue Sep 28, 2004 9:03 pm
Posts: 45
Thanks for your quick reply! :D
I just downloaded the update :)
I'll try it tonight :)


Top
   
 Post subject:
PostPosted: Mon Jul 27, 2009 6:46 am 
Offline

Joined: Tue Sep 28, 2004 9:03 pm
Posts: 45
:( The update is not working. It loads something, and I think I can see some red letters before it immediately reboots. The boot screen still says "Version 1.3 (20061107101950)"
...


Top
   
 Post subject:
PostPosted: Fri Mar 19, 2010 3:29 am 
Offline

Joined: Wed Mar 08, 2006 2:28 am
Posts: 24
Location: Ireland
I have the same problem. The output is
Code:
WARNING: THIS TOOL CAN RENDER YOUR SYSTEM USELESS
YOU BETTER READ THE MANUAL CAREFULLY

Running on machine type 1
Check machine validity (ID=1)
ERROR! Machine invalid for this update
Bye.
Any tips?


Top
   
 Post subject:
PostPosted: Fri Mar 19, 2010 12:42 pm 
Offline
Site Admin

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1589
Location: Austin, TX
Quote:
I have the same problem. The output is
Code:
WARNING: THIS TOOL CAN RENDER YOUR SYSTEM USELESS
YOU BETTER READ THE MANUAL CAREFULLY

Running on machine type 1
Check machine validity (ID=1)
ERROR! Machine invalid for this update
Bye.
Any tips?
We're working on a response to this, please stand by..

_________________
Matt Sealey


Top
   
 Post subject:
PostPosted: Tue Mar 30, 2010 3:24 am 
Offline

Joined: Wed Mar 08, 2006 2:28 am
Posts: 24
Location: Ireland
Anything new about the update?


Top
   
 Post subject:
PostPosted: Tue Mar 30, 2010 12:23 pm 
Offline
Site Admin

Joined: Fri Sep 24, 2004 1:39 am
Posts: 1589
Location: Austin, TX
Quote:
Anything new about the update?
No sorry. I'm at a loss as to why it would not work.

_________________
Matt Sealey


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 20 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group