Power Developer

openSUSE 11 alpha1
Page 1 of 1

Author:  czp [ Mon Jan 21, 2008 3:00 am ]
Post subject:  openSUSE 11 alpha1

openSUSE 11 alpha1 is published, with a 'little' problem: the installer does not work. Alpha1 received a new package solver, so while overall system performance increased, package management is a lot slower (again). Sound drivers are also missing at the moment...

Instead of installation one can use smart or zypper to upgrade to this alpha or factory. If anyone is interested after reading the first paragraph, let me know and I'll write a few hints how to do it :-)

For the rest of the news, please read http://news.opensuse.org/2008/01/18/ann ... 10-alpha1/

Author:  czp [ Mon Feb 11, 2008 4:15 am ]
Post subject: 

Alpha2 was released during the weekend, but it can't be installed, inst32 does not boot on EFIKA or Pegasos. The problem seems to be fixed in factory, so I'm just in the middle of an installation. The new QT4 based user interface of the installer looks very nice, but also makes the installation process slower...

Author:  czp [ Mon Feb 11, 2008 10:11 am ]
Post subject: 

Just finished a successful installation of factory on EFIKA. The look and feel, just as the flow of installation is completely reworked. It looks very nice and logical. KDE 4.0.1 is part of the release and works faster than 3.X did on EFIKA, probably due to lower RAM requirement.

As this is 'factory' and contains the latest and greatest from everything, it also has some bugs. Konqueror crashes on some more complex web pages, XFCE lacks the menu, and only my Logitech mouse worked with X and gpm, the other one (which worked fine with 10.3) did not. Sound support on EFIKAis also missing, hope, that it will be added back soon.

Right now I'm installing factory on my Pegasos, with more RAM it is a bit quicker :-)

Author:  czp [ Mon Feb 18, 2008 7:12 am ]
Post subject: 

Some great news arrived on the factory mailing list: zypper (package manager on openSUSE) will become lightning fast within the next couple of weeks. Check this video to see the difference: http://www.youtube.com/watch?v=XB3o4Skka5Q

As a side note: due to the above changes, factory is now completely broken for any architectures, forget it for now...

Author:  czp [ Thu Feb 21, 2008 1:42 am ]
Post subject: 

Yesterday brought us an installable factory, and now even EFIKA networking is supported again correctly (some modules were missing from inst32, so net install worked only by hack).

Now only if sound worked with 2.6.24+

Author:  Neko [ Thu Feb 21, 2008 7:33 am ]
Post subject: 

Yesterday brought us an installable factory, and now even EFIKA networking is supported again correctly (some modules were missing from inst32, so net install worked only by hack).

Now only if sound worked with 2.6.24+
Sound does work, just it's never autoloaded by any SuSE and you have to manually hack it. The module is supposed to be in the linuxppc-dev tree (non-DMA) and if it isn't yet, it was because of the AC97 hack, which is now totally unecessary anyway.

I only wish we could go back and remove the Efika networking mess from the Linux kernel and all the firmware fixes as it will make some terrible, terrible issues later on with new firmwares which may not completely follow the same device tree style or the efika.forth fixes..

Author:  czp [ Fri Mar 14, 2008 3:13 am ]
Post subject: 

Just tested, there is now a working Java plug-in for FireFox in factory. It is part of the IcedTea flavour of Java, which is still under development, but the sites I tested worked correctly.

Author:  jcmarcos [ Fri Mar 14, 2008 5:51 am ]
Post subject: 

there is now a working Java plug-in for FireFox
What does it mean? Java virtual machine source code for everyone?

Author:  czp [ Fri Mar 14, 2008 6:14 am ]
Post subject: 


And this is now bundled with openSUSE (and others). It is still under development, but much better than nothing...

Author:  czp [ Mon Mar 31, 2008 2:27 pm ]
Post subject: 

Some little, but annoying bugs went the way of the dodo today in factory:

- it is no more suggested to use a CHRP boot partition on EFIKA

- one can set the clock to local time instead of UTC

Some other bugs were introduced of course recently, but these were EFIKA specific, and finally gone :)

Author:  bbrv [ Fri Apr 04, 2008 4:40 am ]
Post subject: 

Hi Peter, how about an update on this?


Author:  czp [ Mon Apr 07, 2008 2:44 am ]
Post subject: 

Not much changed recently, I'm just downloading the latest factory (again...). I also got a good pointer to a documentation, which could help us to create an updated installation source. That would enable us to install additional kernel modules (like sound, if it is not ready on time), or run mkzimage on the installed system to generate a bootable kernel, add a forth script, etc.

Author:  czp [ Tue Apr 08, 2008 9:43 am ]
Post subject: 

Well, I always ask for more testers, but not this time: most likely due to a nice new feature, factory installation results in a system with mixed ppc and x86 packages. So it is better to avoid it for now...

Page 1 of 1 All times are UTC-06:00
Powered by phpBB® Forum Software © phpBB Group