All times are UTC-06:00




Post new topic  Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Jun 02, 2012 6:16 am 
Offline

Joined: Sat Jun 02, 2012 3:25 am
Posts: 3
Yesterday I received my nettop unit. I think I read that hardware decoding for video is not supported yet, correct? using the video player, it is impossible to have the device do something else at the same time. for example, I can't properly play video from files residing on my home server. Is it planned to support the HW decoder?


Top
   
PostPosted: Sat Jun 02, 2012 11:58 am 
Offline

Joined: Sun Mar 27, 2011 1:18 pm
Posts: 183
Location: Hornell, NY
Quote:
Yesterday I received my nettop unit. I think I read that hardware decoding for video is not supported yet, correct? using the video player, it is impossible to have the device do something else at the same time. for example, I can't properly play video from files residing on my home server. Is it planned to support the HW decoder?
If the video player you are using is totem it should be using the VPU via our gstreamer plugins. we don't have the acceleration working with other players.

Also depending on the network speed and method used for file sharing it may be slowing things down a bit. try copying one of the videos to the local disk and try playing it from there and see if it makes a difference.


Top
   
PostPosted: Mon Jun 04, 2012 1:26 am 
Offline

Joined: Sat Jun 02, 2012 3:25 am
Posts: 3
I did do that and I'm using Totem, the standard player that came with the installed Ubuntu Maverick distribution. First problem I encountered was the player requesting plug-ins for .mpg and .mp4 files. The player chose to install g-streamer and ffmpeg plug-ins.
Playing a file from the local disk, still shows over 90% CPU usage. This can only be the case if HW acceleration is not used. Would you agree?
I'm wondering if the specific Maverick version for this unit was not killed by auto-updates. Should I re-install the specific image?

UPDATE:
I re-installed with latest image from this site. Nothing changes: the video performance is very bad. 100% CPU on an MP4 file for the local SSD. Am really disappointed with the SW on this EFICA MX smattop. I'm convinced this chip can do a lot better, but there is a lack of proper drivers for linux. I'm going to try the android demo to see how that performs. I'd assume the chip was built for that in the 1st place.
In its current state, it is unusable as desktop replacement. Even web browsing with firefox is rather slow.


Top
   
 Post subject:
PostPosted: Thu Jun 07, 2012 10:54 am 
Offline

Joined: Sun Mar 27, 2011 1:18 pm
Posts: 183
Location: Hornell, NY
Since you are already trying different images could you try my squeeze desktop image and tell me how that works out? I think it performs a tad bit better than maverick myself. I'm only asking this so I can perhaps compare it to maverick and see what's going on there.

http://www.powerdeveloper.org/forums/vi ... php?t=2262

also one thing to keep in mind is the acceleration is only really for up to 720p videos. some higher res vids will play just fine though but not all.


using my squeeze image right now playing some videos and looking at htop most videos use around 30 to 45% cpu and at least one used between 40 and 70% it all depends on how the videos are encoded.

anyway please give it a shot and let me know if it's still a problem on my squeeze image because that image has improvements to the hardware/multimedia support packages that I've been working on for a while now. (mostly PulseAudio config stuff)

Also if it is a free video could you point me at the video file that is causing you trouble?


Top
   
 Post subject:
PostPosted: Mon Jun 11, 2012 2:54 am 
Offline

Joined: Sat Jun 02, 2012 3:25 am
Posts: 3
Thanks for the link. I'll give it a go.
The video is a personal copy of a DVD, so can't share in order not to violate fair use policy. It is a H.264 encoded stream at 720x576 (SD resolution).


Top
   
 Post subject:
PostPosted: Thu Jun 14, 2012 11:43 am 
Offline

Joined: Thu Oct 19, 2006 7:19 am
Posts: 271
Location: Italy/Greece
i'm not a gnome fan thus i tried to use a different gstreamer based video player like 'xfce/parole' but i got this error:
Code:
acrux@efikamx:~$ parole Downloads/071023_animatic_blog.avi
[INFO] Product Info: i.MX51
VPU Version: firmware 13.4.32; libvpu: 5.1.4
MFW_GST_VPU_DECODER_PLUGIN 2.0.1-1 build on Apr 2 2012 23:42:59.
[WARN] VPU iram is less than needed, some parts don't use iram
width_align = 0, height_align = 0

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

(parole:7745): GStreamer-CRITICAL **: gst_pad_push: assertion `GST_IS_BUFFER (buffer)' failed

>>VPU_DEC: State: Ready to Null
^C

_________________
acrux _at_ linuxmail _dot_ org


Top
   
 Post subject:
PostPosted: Wed Jun 20, 2012 8:25 pm 
Offline

Joined: Sun Mar 27, 2011 1:18 pm
Posts: 183
Location: Hornell, NY
As far as I know the gstreamer plugins were only tested with totem (and perhaps a shell script) I can't get it to play anything with parole either. but If I do manage to get it working I will let you know.

I might run this by the guy that did our gstreamer plugins but he is quite busy on other things at the moment. I don't think totem pulls in all of gnome so I would just use that for the moment.

Would be nice to have it working with other gstreamer based players though.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: Google [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group