All times are UTC - 6 hours




Post new topic Reply to topic  [ 21 posts ]  Go to page Previous  1, 2
Author Message
 Post subject:
PostPosted: Thu Aug 26, 2010 2:51 pm 
Offline


Tue Mar 31, 2009 10:24 pm

171
lu_zero wrote:
oprofile seems working correctly on the efika. You might try to use it.

thanks for the tip, Luca!

after building a profiling-enabled 2.6.31.12.3 kernel, the oprofile specialized driver, and oprofile itself (with kernel support enabled, naturally), i can now run oprofile sessions. alas, my testbed app developed one peculiar problem since then..

everything loads up and runs fine to the first swapBuffers or thereabout, where it appears to get stuck. after a while the kernel announces that the app has been blocked for 120s, and things go downhill from there.

the truly peculiar part is that the above happens even outside of oprofile sessions.

same thing happens to /usr/bin/simple_draw - judging by its log messages it does not get to complete its first frame either.

so here comes the mandatory question: has anybody successfully run an EGL/ES app under oprofile and/or a profile-enabled kernel on EfikaMX? needless to say, guidelines and tips from successful scenarios are welcome.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 18, 2010 6:27 pm 
Offline


Tue Mar 09, 2010 10:41 am

19
Hi Martin,

just curious and don't want to start a new thread for this - did you ever try to get Anti Aliasing working? Would be interesting to see how this affects Performance.

I could not find any infos anywhere how this can be enabled?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 19, 2010 7:52 am 
Offline


Tue Mar 31, 2009 10:24 pm

171
slyd wrote:
Hi Martin,

just curious and don't want to start a new thread for this - did you ever try to get Anti Aliasing working? Would be interesting to see how this affects Performance.


I haven't tinkered much with antialiasing on the platform, beyond checking that it works. It's rather costly in the current GL stack - 4x antialiasing practically halves the fillrate. So it's not as costly as SSAA, but it's still expensive for MSAA.

Quote:
I could not find any infos anywhere how this can be enabled?

It's really simple. Just add to your config record:
Code:
EGL_SAMPLE_BUFFERS, 1
EGL_SAMPLES, N

where N is one of the supported SAMPLES per the available configs as reported by the EGL stack. I.e. for the current EGL stack, it can be either 0, 2 or 4 (the first obviously being no AA).


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 20, 2010 9:33 am 
Offline


Tue Mar 31, 2009 10:24 pm

171
Since there is clearly interest in that functionality, I've updated ntsh-jass and test-es to support FSAA through a command-line switch to the respective apps.

Also, EGL surface configs handling has been enhanced to include non-conformant surfaces too, which provides access to 2x FSAA modes in the current EGL stack. Which modes, apropos, are quite usable performance-wise (~15% fillrate hit).


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 20, 2010 9:40 am 
Offline


Tue Mar 09, 2010 10:41 am

19
oh look smooth edges 8)

Thank you very much, exactly what I needed to know.

Btw. very nice Blog Posts about the GPU Performance.
:)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 20, 2010 10:26 am 
Offline


Tue Mar 31, 2009 10:24 pm

171
Thanks, slyd. We'll get this baby rolling at full speed soon.

Apropos, in case you've already seen the pixel-counting AMD_performance_monitor counters - check them out now with FSAA on ; )


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page Previous  1, 2

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group